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Introduction to Computer 

Computer 

A computer is an electronic device, operating under the control of 

instructions stored in its own memory that can accept data (input), process the 

data according to specified rules, produce information (output), and store the 

information for future use. 

Functionalities of a computer 

Any digital computer carries out five functions in gross terms: 

 Takes data as input  

 Stores the data / instructions in its memory and use them when required  

 Processes the data and converts it into useful information. 

 Generates the output. 

 Controls all the above four steps. 

 

 

 

 

 

Computer Components 

Any kind of computers consists of Hardware and Software. 

Hardware: 

Computer hardware is the collection of physical elements that constitutes 

a computer system. Computer hardware refers to the physical parts such as the 

monitor, mouse, keyboard, computer data storage, hard drive disk (HDD), 

system unit (graphic cards, sound cards, memory, motherboard and chips), etc.  
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Input Devices 

Input device is any peripheral . Input device Translate data from form 

that humans understand to one that the computer can work with. Most common 

are keyboard and mouse 

 

 

 

 

 

 

 

 

 

 

Example of Input Devices:- 

Keyboard Mouse(Pointing 

device) 

Microphone 

Touch screen Scanner Web camera 

Touchpads MIDI keyboard Graphics Tablets 

Cameras Pen Input Electronic Whiteboard 

Video Capture 

Hardware 

Microphone Trackballs 

Barcode reader Digital camera Joystick 
 

Central Processing Unit (CPU) 

A CPU is brain of a computer. It is responsible for all functions and 

processes. The CPU is the most important element of a computer system. 

The CPU is comprised of three main parts : 

* Arithmetic Logic Unit (ALU): Executes all arithmetic and logical operations. Arithmetic 

calculations like as addition, subtraction, multiplication and division. Logical operation 

like compare numbers, letters, or special characters 

* Control Unit (CU): controls and co-ordinates computer components. 

1. Read the code for the next instruction to be executed. 

2. Increment the program counter so it points to the next instruction. 

3. Read whatever data the instruction requires from cells in memory. 

4. Provide the necessary data to an ALU or register. 

5. If the instruction requires an ALU or specialized hardware to complete, instruct the 

hardware to perform the requested operation. 
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* Registers :Stores the data that is to be executed next, "very fast storage area". 

Primary Memory:- 

1. RAM: Random Access Memory (RAM) is volatile in nature, which means 

that data will be erased once supply to the storage device is turned off. RAM 

stores data randomly and the processor accesses these data randomly from 

the RAM storage.  

2. ROM (Read Only Memory): ROM is a permanent form of storage. ROM 

devices do not allow data stored on them to be modified. 

Secondary Memory:- 

Stores data and programs permanently :its retained after the power is turned off 

1. Hard drive (HD): A hard disk is part of a unit, often called a "disk drive," 

"hard drive," or "hard disk drive," that store and provides relatively quick 

access to large amounts of data on an electromagnetically charged surface or 

set of surfaces. 

2. Optical Disk: an optical disc drive (ODD) is a disk drive that uses laser light 

as part of the process of reading or writing data to or from optical discs. Some 

drives can only read from discs, but recent drives are commonly both readers 

and recorders, also called burners or writers. CDs can store up to 700 

megabytes (MB) of data and DVDs can store up to 8.4 GB of data.  

3. Flash Disk 

A storage module made of flash memory chips. A Flash disks have no 

mechanical platters or access arms, but the term "disk" is used because the data 

are accessed as if they were on a hard drive.  
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Output devices 

An output device is any piece of computer hardware equipment used to 

communicate the results of data processing carried out by an information 

processing system (such as a computer) which converts the electronically 

generated information into human-readable form. 

 

 

 

 

 

 

 

 

 

Example on Output Devices: 

 Monitor  LCD Projection Panels 

 Printers(all types)  Computer Output Microfilm (COM) 

 Plotters  Speaker(s) 

 Projector   

 

Note Basic types of monitors are a.Cathode Ray Tube (CRT). B. Liquid Crystal 

Displays (LCD). c.light-emitting diode (LED). Printer types: 1-Laser Printer. 

2-Ink Jet Printer. 3-Dot Matrix Printer 

Software 

Software is a generic term for organized collections of computer data and 

instructions, often broken into two major categories: system software that 

provides the basic non-task-specific functions of the computer, and application 

software which is used by users to accomplish specific tasks. 

Software Types 

A. System software Generally, system software consists of an operating system 

and some fundamental utilities such as disk formatters, file managers, 

display managers, text editors, user authentication (login) and management 

tools, and networking and device control software. 
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B. Application software Application software may consist of a single program, 

such as an image viewer; a small collection of programs (often called a 

software package) that work closely together to accomplish a task. 

 

 

Comparison Application Software and System Software 

 

System Software  Application Software 

 Computer  software,  or  just  software  is  a   

 

general term primarily used for digitally 

stored Application software, also known as an 

 

data  such  as  computer  programs  and  

other application or an "app", is computer software 

 kinds  of  information  read  and  written  by designed to help the user to perform specific 

 computers.   App   comes   under   computer tasks. 

 software though it has a wide scope now.   

Example: 

1) Microsoft Windows 

1

) Opera (Web Browser) 

 2

) Microsoft Word (Word Processing)  

2) Linux  3

) Microsoft Excel (Spreadsheet software)  

3) Unix  4

) MySQL (Database Software)  

4) Mac OSX  5

) 

Microsoft PowerPoint (Presentation 

Software)  

5) DOS  6

) Adobe Photoshop (Graphics Software)   

Interaction: 

Generally, users do not interact with system  

Users always interact  with application 

software 

 

while doing different activities.  

  software as it works in the background.    

   

Dependency: 

System software can run independently of 

the Application  software  cannot  run  without  the 

 application software. presence of the system software. 

 

Unit of Measurements 

Storage measurements: The basic unit used in computer data storage is called 

a bit (binary digit). Computers use these little bits, which are composed of ones 

and zeros, to do things and talk to other computers. All your files, for instance, 

are kept in the computer as binary files and translated into words and pictures 

by the software (which is also ones and zeros). This two number system, is 

called a “binary number system” since it has only two numbers in it. The 

decimal number system in contrast has ten unique digits, zero through nine. 
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Computer Storage units 

 

Bit BIT 0 or 1 

Kilobyte KB 1024 bytes 

Megabyte MB 1024 kilobytes 

Gigabyte GB 1024 megabytes 

Terabyte TB 1024 gigabytes 

 

Speed measurement: The speed of Central Processing Unit (CPU) is measured 

by Hertz (Hz), which represent a CPU cycle. The speed of CPU is known as 

Computer Speed. 

 

 CPU SPEED MEASURES 

1 hertz or Hz 1 cycle per second 

1 MHz 1 million cycles per second or 1000 Hz 

1 GHz 1 billion cycles per second or 1000 MHz 

 

Computers classification 

Computers can be generally classified by size and power as follows, though 

there is Considerable overlap: 

• Personal computer: A small, single-user computer based on a microprocessor. 

In addition to the microprocessor, a personal computer has a keyboard for 

entering data, a monitor for displaying information, and a storage device 

for saving data. 

• workstation : A powerful, single-user computer. A workstation is like a 

personal computer, but it has a more powerful microprocessor and a 

higher-quality monitor. 
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• minicomputer : A multi-user computer capable of supporting from 10 to 

hundreds of users simultaneously. 

• mainframe : A powerful multi-user computer capable of supporting many 

hundreds or thousands of users simultaneously. 

• supercomputer : An extremely fast computer that can perform hundreds of 

millions of instructions per second. 

 

 

 

 

Laptop and Smartphone Computers 

LAPTOP: A laptop is a battery or AC-powered personal computer that can be 

easily carried and used in a variety of locations.  

Netbook: A netbook is a type of laptop that is designed to be even more 

portable. Netbooks are often cheaper than laptops or desktops. They are 

generally less powerful than other types of computers, but they provide enough 

power for email and internet access, which is where the name "netbook" comes 

from. 

Mobile Device: A mobile device is basically any handheld computer. Some 

mobile devices are more powerful, and they allow you to do many of the same 

things you can do with a desktop or laptop computer.  

Tablet Computers: Like laptops, tablet computers are designed to be portable. 

However, they provide a very different computing experience.  

Smartphones: A smartphone is a powerful mobile phone that is designed to 

run a variety of applications in addition to phone service.  

Characteristics of Computer 

• Speed: The computer can process data very fast, at the rate of millions of 

instructions per second.. 

• Accuracy: Computer provides a high degree of accuracy. For example, the 

computer can accurately give the result of division of any two numbers 

up to 10 decimal places. 

• Diligence: When used for a longer period of time, the computer does not get 

tired or fatigued.  

• Storage Capability: Large volumes of data and information can be stored in  

               computer and also retrieved whenever required.  
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Computer Viruses 

Viruses: A virus is a small piece of software that piggybacks on real programs. 

For example, a virus might attach itself to a program such as a 

spreadsheet program. Each time the spreadsheet program runs, the virus 

runs, too, and it has the chance to reproduce (by attaching to other 

programs) or wreak havoc. 

•E-mail viruses: An e-mail virus travels as an attachment to e-mail messages, 

and usually replicates itself by automatically mailing itself to dozens 

of people in the victim's e-mail address book.  

•Trojan horses: A Trojan horse is simply a computer program. The program 

claims to do one thing (it may claim to be a game) but instead does 

damage when you run it (it may erase your hard disk). Trojan horses 

have no way to replicate automatically. 

•Worms: A worm is a small piece of software that uses computer networks and 

security holes to replicate itself. A copy of the worm scans the 

network for another machine that has a specific security hole. It 

copies itself to the new machine using the security hole, and then 

starts replicating from there, as well. 

What are some tips to avoid viruses and lessen their impact?* 

 Install anti-virus software. Update it and use it regularly. 

 Use a virus scan before you open any new programs or files that may 

contain executable code. This includes packaged software that you buy 

from the store as well as any program you might download from the 

Internet. 

 If you are a member of an online community or chat room, be very 

careful about accepting files or clicking links that you find or that 

people send you within the community. 

 Make sure you back up your data (documents, bookmark files, important 

email messages, etc.) on disc so that in the event of a virus infection, 

you do not lose valuable work. 

Microsoft Excel 2010  
 

Excel is a spreadsheet program in the Microsoft Office system. You can 

use Excel to create and format workbooks (a collection of spreadsheets) in order 

to analyze data and make more informed business decisions. Specifically, you 

can use Excel to track data, build models for analyzing data, write formulas to 
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perform calculations on that data, pivot the data in numerous ways, and present 

data in a variety of professional looking charts. 

 

 

Getting Started 

Now that you have an understanding of where things are located, let’s look at 

the steps needed to create an Excel document. 

Opening Outlook 

You may have a 

shortcut to Word on 

your desktop, if so 

double click the icon 

and Word will open.  If 

not follow the steps 

below: 

1.  Click on the Start 

button 

2.  Highlight Programs 

3.  Highlight Microsoft 

Office 

4.  Click on Microsoft 

Excel 2010 

Create a New Workbook 

1.  Click the File tab and then click New. 

2.  Under Available Templates, double click Blank Workbook or Click 

Create. 

 

Find and Apply Template 

Excel 2010 allows you to apply built-in templates and to search from a variety 

of templates on 

Office.com. To find a template in Excel 2010, do the following: 

1.  On the File tab, click New. 

2.  Under Available Templates, do one of the following: 
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a.  To reuse a template that you’ve recently used, click Recent 

Templates, click the template that you want, and then click 

Create. 

b.  To use your own template that you already have installed, click 

My Templates, select the template that you want, and then click 

OK. 

c.   To find a template on Office.com, under Office.com Templates, 

click a template category, select the template that you want, and 

then click Download to download the template from Office.com 

to your computer. 

3.  Once you click on the template you like it will open on your screen as a 

new document. 

Enter Data in a Worksheet 

1.  Click the cell where you want to enter data. 

2.  Type the data in the cell. 

3.  Press enter or tab to move to the next cell. 

 

Save a Spreadsheet 

To save a document in the format used by Excel 2010 and Excel 2007, do the 

following: 

1.  Click the File tab. 

2.  Click Save As. 

3.  In the File name box, enter a name for your document. 

4.  Click Save. 

To save a document so that it is compatible with Excel 2003 or earlier, do the 

following: 

1.  Click the File tab. 

2.  Click Save As. 

3.  In the Save as type list, click Excel 97-2003 Document. This changes 

the file format to .xls. 

4.  In the File name box, type a name for the document. 

5.  Click Save. 

Print Preview 



11 

 

Print Preview automatically displays when you click on the Print tab. 

Whenever you make a change to a print-related setting, the preview is 

automatically updated. 

1.  Click the File tab, and then click Print. To go back to your document, 

click the File tab. 

2.  A preview of your document automatically appears. To view each 

page, click the arrows below the preview. 

 

Print a Worksheet 

1.  Click the worksheet or select the worksheets that you want to print. 

2.  Click File 

3.  Click Print. 

4.  Once you are on the Print screen you can 

select printing options:    To change the 

printer, click the drop-down box under 

Printer,and select the printer that you 

want. 

  To make page setup changes, including 

changing page orientation, paper size, 

and page margins, select the options 

that you want under Settings. 

  To scale the entire worksheet to fit on 

a single printed page, under Settings, 

click the option that you want in the 

scale options drop-down box. 

  To print the specific information, select 

Print Active Sheets or Print Entire 

Workbook 

 

The Ribbon 

Understanding the Ribbon is a great way to help understand the changes 

between Microsoft 2003 to Microsoft 2010. The ribbon holds all of the 

information in previous versions of Microsoft Office in a more visual stream 

line manner through a series of tabs that include an immense variety of program 

features. 
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Home Tab 

This is the most used tab; it incorporates all text and cell formatting features 

such as font and paragraph changes.  The Home Tab also includes basic 

spreadsheet formatting elements such as text wrap, merging cells and cell style. 
 

 

 

 

 

 

 

Under the Home tab, we have 7 groups:- 

1- Clipboard  2 – Font    3 – Alignment   4- Number  5- style    6- cell     7- 

editing   

1)    Clipboard: – This group contains frequently used commands: Cut, 

Copy, Paste and Format painter. Clipboard option allows us to collect text 

and graphic items and paste it. 

 
 

2)    Font: – We use this option to change the font style and font-size. We can 

make it bold, italic and underline. Also, this group contains border styles, fill 

color, font color. 

 
 

3)    Alignment: – We use this option to change the alignment of cell’s text to 

the right, left and middle. Also, we can subject the text to top, bottom, and 

middle alignment. In this group, we have Wrap text option to adjust and make 

the text visible within a cell, and we can also merge 2 or more cells, using merge 

option. 

http://www.exceltip.com/wp-content/uploads/2015/07/image-315.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-414.png
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https://www.exceltip.com/basic-excel/page-layout-tab.html 

 

4) Number: – We use this option to change the number formatting into General, 

Percentage, Currency, Date, Time, Fraction etc. We can increase and decrease 

the decimal and convert the number into accounting number. 

 

 5) Styles: – In this option, we have Conditional Formatting, Format as Table 

and Cell Styles. Conditional formatting is used to highlight the cell or range on 

the basis of conditions. Format as table is having readymade table format and 

Cell styles feature different types of built-in styles that are a combination of 

Font style, Font color and Fill color. 

 

 6)  Cells: – We use this option to insert or delete cells, rows, columns and 

sheets. Also, we have format option to adjust the height, width of cells or range. 

Using this option, we can hide or unhide the range, protect the workbook, 

rename the sheet name, fill the tab color, move or copy to sheets, lock the cells. 

 

 7) Editing: – This option has Auto Sum feature to return the total of numbers 

and move the text to right, left, up and down, Clear the format, content, 

comments and hyperlink; sort the data and find and select option. 

https://www.exceltip.com/basic-excel/page-layout-tab.html
http://www.exceltip.com/wp-content/uploads/2015/07/image-56.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-65.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-75.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-85.png
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Select Cells or Ranges 

In order to complete more advanced processes in Excel you need to be able to 

highlight or select cells, rows and columns. There are a variety of way to do this, 

see the table below to understand the options. 

 

 

To select Do this 

A single cell Click the cell, or press the arrow keys to move to the cell. 

A range of cells                         Click the first cell in the range, and then drag to the last 

cell, or hold  down SHIFT while you press the arrow 

keys to extend the selection. 

A large range of cells               Click the first cell in the range, and then hold down 

SHIFT while you click  the last cell in the range. You can 

scroll to make the last cell visible.    

All cells on a worksheet  

                     Click the Select All button or press        

                         CTRL+A 

Non-adjacent cells or 

cell ranges 

 

Select the first cell or range of cells, and then hold down 

CTRL while you select the other cells or ranges. 

NOTE: You cannot cancel the selection of a cell or range 
of cells in a Non-adjacent selection without canceling the 
entire selection. 
 

An entire row or column                                  Click the row or column heading. 

1-Row heading 

2-Column heading 

 

Adjacent rows or 

columns      

Drag across the row or column headings. Or select the first 

row or column;  then hold down SHIFT while you select 

the last row or column. 

Non-adjacent rows 

or columns 

 

Click the column or row heading of the first row or 

column in your selection; then hold down CTRL while 

you click the column or row headings of other rows or 

columns that you want to add to the selection 

http://www.exceltip.com/wp-content/uploads/2015/07/image-95.png
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NOTE: To cancel a selection of cells, click any cell on the worksheet.  This 

is not applicable to cells with formulas in it. 

 

 

Modifying Spreadsheets 

In order to create an understandable and 

professional document you will need to make 

adjustments to the cells, rows, columns and 

text.  Use the following processes to assist 

when creating a spreadsheet. 

Cut, Copy, and Paste Data 

You can use the Cut, Copy, and Paste commands in 

Microsoft Office Excel to move or copy entire cells or 

their contents.  NOTE: Excel displays an animated 

moving border around cells that have been cut or copied. 

To cancel a moving border, press ESC. 

 

Move/Copy Cells 

When you move or copy a cell, Excel moves or 

copies the entire cell, including formulas and 

their resulting values, cell formats, and 

comments. 

1.  Select the cells that you want to move or copy. 

2.  On the Home tab, in the Clipboard group, do one of the following: 

a.  To move cells, 

click Cut . b.   

  

Cells to the last used cell 

on the worksheet (lower- 

right corner) 

Select the first cell, and then press CTRL+SHIFT+END 

to extend the selection of cells to the last used cell on the 

worksheet (lower-right corner). 

Cells to the beginning of the Select the first cell, and then press 
CTRL+SHIFT+HOME to extend the worksheet selection of cells to the beginning 
of the worksheet. 
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To copy cells, click 

Copy . 

3.  Click in the center of the cell you would like to Paste the information too. 

4.  On the Home tab, in the Clipboard group, click Paste . 

NOTES: Excel replaces existing data in the paste area when you cut and 

paste cells to move them. When you copy cells, cell references are 

automatically adjusted. If the selected copy or paste area includes hidden 

cells, Excel also copies the hidden cells. You may need to temporarily 

unhide cells that you don't want to include when you copy information. 

 

 

 

 

Move/Copy Cells with Mouse 

1.  Select the cells or a range of cells that you want to move or copy. 

2.  To move a cell or range of cells, point to the border of the selection. 

When the pointer becomes a move pointer , drag the cell or range of 

cells to another location. 

Column Width and Row Height 

On a worksheet, you can specify a 

column width of 0 to 255 and a row 

height of 0 to 409. This value 

represents the   number of characters 

that can be displayed in a cell that is 

formatted with the standard font. The 

default column width is 8.43 

characters and the default row height 

is 12.75 points. If a column/row has 

a width of 0, it is hidden. 

Set Column/Row Width/Height 

1.  Select the column(s) or row(s) that you want 

to change. 

2.  On the Home tab, in the Cells group, click 

Format. 
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3.  Under Cell Size, click Column Width or 

Row Height. 

4.  A Column Width or Row Height box will 

appear. 

5.  In the Column Width or Row Height box, 

type the value that you want your column or 

row to be. 

Automatically Fit Column/Row Contents 

1.  Click the Select All button 

2.  Double-click any boundary 

between two column/row 

headings. 

3.  All Columns/Rows in the entire worksheet will be 

changed to the new  Size. 

NOTE: At times, a cell might display #####. This can occur when the cell 

contains a number or a date that exceeds the width of the cell so it cannot 

display all the characters that its format requires.  To see the entire contents 

of the cell with its current format, you must increase the width of the 

column. 

 

Set Column/Row Width/Height with Mouse 

   To change the width of one column/row 

1.  Place you cursor on the line between two 

rows or columns. 

2.  A symbol that looks like a lower case t 

with arrows on the horizontal line will 

appear 

3.  Drag the boundary on the right side of 

the column/row heading until the 

column/row is the width that you want. 

   To change the width of multiple columns/rows 

1.  Select the columns/rows that you want to change 

2.  Drag a boundary to the right of a selected column/row heading. 

3.  All selected columns/rows will become a different size. 

   To change the width of columns/rows to fit the contents in the cells 
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1.  Select the column(s) or row(s) that you want to change 

2.  Double-click the boundary to the right of a selected column/row 

heading. 

3.  The Column/Row will automatically be size to the length/height of the 

longest/tallest text. 
 

Merge or Split Cells 

When you merge two or more adjacent horizontal or vertical cells the cells 

become one larger cell that is displayed across multiple columns or rows. 

When you merge multiple cells, the contents of only one cell appear in the 

merged cell. 

 

 

 

 

 

Merge and Center Cells 

1.  Select two or more adjacent cells that you want to merge. 

2.  On the Home tab, in the Alignment group, click Merge and Center. 

3.  The cells will be merged in a row or column, and the cell contents will be 

centered in the merged cell. 

Merge Cells 

To merge cells only, click the arrow next to Merge and Center, and then 

click  Merge Across or Merge Cells. 
 
 
 
 
 
 
 

Split Cells 

1.  Select the merged cell you want to split 

2.  To split the merged cell, click Merge and Center .  The cells will split 

and the contents of the merged cell will appear in the upper-left cell of the range 

of split cells. 
 
Automatically Fill Data 

To quickly fill in several types of data series, you can select cells and drag the 

fill handle.  To use the fill handle, you select the cells that you want to use as 

javascript:AppendPopup(this,'24282240_2')
javascript:AppendPopup(this,'24282240_2')
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a basis for filling additional cells, and then drag the fill handle across or down 

the cells that you want to fill. 

1. Select the cell that contains the formula that you want to be brought to other 

cells. 

2. Move your curser to the small black square in the lower-right corner of a 

selected cell also know as the fill handle.  Your pointer will change to a 

small black cross.  

3.  Click and hold your mouse then drag the fill handle across the cells, 

horizontally to the right or vertically down, that you want to fill. 

4.  The cells you want filled will have a gray looking border around them. 

Once you fill all of the cells let go of your mouse and your cells will be 

populated. 

 

 

 

Formatting Spreadsheets 

To further enhance your spreadsheet you can format a number of elements such 

as text, numbers, coloring, and table styles.  Spreadsheets can become 

professional documents used for company meetings or can even be published. 

Wrap Text 

You can display multiple lines of text inside a cell 

by wrapping the text. Wrapping text in a cell does 

not affect other cells. 

1.  Click the cell in which you want to wrap the 

text. 

2.  On the Home tab, in the Alignment group, 

click Wrap Text. 

3.  The text in your cell will be wrapped. 

NOTE: If the text is a long word, the characters won't 

wrap (the word won't be split); instead, you can widen 

the column or decrease the font size to see all the text. 

If all the text is not visible after you wrap the text, you 

might have to adjust the height of the row. On the 
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1. Click the cell(s) that contains the numbers that you want to format.  
 
 

that 

2. On the Home tab, in the Number group, click the arrow next to the 
 Number Format box, and then click the format you want.   

 

 

   

 

Home tab, in the Cells group, click Format, and then 

under Cell Size click AutoFit Row 
 

Format Numbers 

In Excel, format of a cell is separate from the data that is stored in the cell. This 

display difference can the have a significant effect when the data is numeric.  

For example, numbers in cells will default as rounded numbers, date and time 

may not appear as anticipated.  After you type numbers in a cell, you can change 

the format in which they are displayed to ensure the numbers in your 

spreadsheet are displayed as you intended. 

 

 

 

 

 

 

 

 

 

 

If you are unable to format numbers in the detail you would 

like that you can click on the More Number Formats at 

the bottom of the Number Format drop down list. 

1. In the Category list, click the format that you want to 

use, and then adjust settings to the right of the Format 

Cells dialog box.  For example, if you’re using the 

Currency format, you can select a different currency 

symbol, show more or fewer decimal places, or 

change the way negative numbers are displayed.    
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Cell Borders 

By using predefined border styles, you can quickly add a border around cells or 

ranges of cells. If predefined cell borders do not meet your needs, you can create 

a custom border. 

NOTE: Cell borders that you apply appear on printed pages. If you do not use 

cell borders but want worksheet gridline borders for all cells to be visible on 

printed pages, you can display the gridlines. 

Apply Cell Borders 

1. On a worksheet, select the cell or range 

of cells that you want to add a border to, 

change the border style on, or remove a 

border from. 

2.  Go to the Home tab, in the Font group 

3.   Click the arrow next to Borders  

4.  Click on the border style you would like 

5.  The border will be applied to the cell or cell 

range 

NOTE: To apply a custom border style, click 

More Borders. In the Format Cells dialog box, 

on the Border tab, under Line and Color, click 

the line style and color that you want. 

Remove Cell Borders 

1.  Go to the Home tab, in the Font group 

2.   Click the arrow next to Borders  

javascript:AppendPopup(this,'23456783_1')
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3.  Click No Border . 

NOTES: The Borders button displays 

the most recently used border style. You 

can click the Borders button (not the 

arrow) to apply that style. 

 

Cell Styles 

You can create a cell style that includes a custom border, colors and accounting 

formatting. 

1. On the Home tab, in the Styles group, click Cell Styles. 

2. Select the different cell style option you would like applied to your 

spreadsheet. 

 

 

 

 

 

 

 

 

 

 

 

NOTE: If you would like to apply a cell fill and a cell border, select the cell fill 

color first the ensure both formats are applied. 

Cell and Text Coloring 

You can also modify a variety of cell and text colors manually. Cell Fill 

1.  Select the cells that you want to apply or remove a fill color from. 

2.  Go to the Home tab, in the Font 

group and select one of the following 

options: 

a. To fill cells with a solid color, click the arrow 

next to Fill  
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Color , and then under Theme Colors or 

Standard 

Colors, click the color that you want. 

b. To fill cells with a custom color, click the 

arrow next to Fill Color , click More 

Colors, and then in the Colors dialog box 

select the color that you want. 

c.  To apply the most recently selected color, 

click Fill Color   

. 
 

NOTE: Microsoft Excel saves your 10 most recently selected custom colors. 

To quickly apply one of these colors, click the arrow next to Fill Color , and 

then click the color that you want under 

Recent Colors. 
 

Remove Cell Fill 

1.  Select the cells that contain a fill color or fill pattern. 

2.  On the Home tab, in the Font group, click the arrow next to Fill 

Color, and then click No Fill. 
 

Text Color 

1. Select the range of cells, text, or characters that 

you want to format with a different text color. 

2. On the Home tab, in the Font group and select 

one of the following options: 

 

a.  To apply the most recently selected text color, click Font Color  

b.  To change the text color, click the arrow next to Font Color , 

and then under Theme Colors or Standard Colors, click the color 

that you want to use. 
 

Bold, Underline and Italics Text 

1.  Select the cell range of cells, or text. 

2.  Go to the Home tab, in the Font 

group 
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3.  Click on the Bold (B) Italics (I) or 

Underline (U) commands. 

4.  The selected command will be 

applied. 

 

Customize Worksheet Tab 

1.  On the Sheet tab bar, right-click the 

sheet tab that you want to customize 

2.  Click Rename to rename the sheet or 

Tab Color to select a tab color. 

3.  Type in the name or select a color you 

would like for your spreadsheet. 

4.  The information will be added to the tab 

at the bottom of the spreadsheet. 
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Insert Tab 

This tab allows you to insert a variety of items into a document from pictures, 

clip art, and headers and footers. 

 
 
 
 
 
 
 
 

 
 
 

 

9 groups of insert tab  

1- Tables     2- Illustration     3- charts   4- Reports     5- sparklines  

6- Filter      7- Links     8- Links      9- Text         10 – symbols 

 

We use Insert tab to insert the picture, charts, filter, hyperlink etc. We use this 

option to insert the objects in Excel. To open the insert tab, press shortcut keys 

Alt+N. 

 

 

1)    Tables: - We use this option to insert the dynamic table, Pivot table and 

recommended table. Pivot table is used to create the summary of report with 

the built-in calculation, and we have option to make our own calculation. Tables 

make it easy to sort, filter and format the data within a sheet. This option is also 

having recommended table that means on the basis of data, we can just insert 

the table as per the Excel’s recommendation. 

 
 
 
 
 

http://www.exceltip.com/wp-content/uploads/2015/07/image-125.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-316.png
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2)    Illustration: - We use this option to insert the Pictures, Online Pictures, 

Shapes, SmartArt and Screenshot. It means if we want to insert any image, we 

can use Illustration feature. 

 

3)    Charts: -Charts is very important and useful function in Excel. In excel, 

we have different and good numbers of readymade chart options.  We have 8 

types of different charts in Excel:- Column, Bar, Radar, Line, Area, Combo, Pie 

and Bubbles chart. We can insert Pivot chart as well as Recommended chart, and 

if we don’t know which chart we should insert for the data, we can use this 

option to fulfil the requirement. 

 

  

4)    Reports: -We use this option to create a better report on the basis of the 

decisions we take for business. It makes the report more  interactive and 

decipherable. 

 

5) Sparklines: -Sparkline is a very tricky and useful option added by Microsoft 

Excel. On the basis of a range, it can visualize the trends in a single cell as 

charts. We have 3 different types of cell charts:- Line, Column and Win/Loss 

chart. 

 

http://en.wikipedia.org/wiki/Pivot_chart
http://www.exceltip.com/wp-content/uploads/2015/07/image-415.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-66.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-76.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-86.png
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6) Filters: -We use this option to filter data visually and filter dates 

interactively. We have 2 options: Slicers and Timeline. We use Slicer to make 

the fast and easier to filter tables, Pivot tables, Pivot Charts and cube functions. 

Timeline makes it faster and easier to select time periods in order to filter Pivot 

Tables, Pivot Charts and Cube function. 

 

  

7)    Links: - 

 We use this option to create the link in the document for the quick access to 

webpage and files. 

 We can also use it to access different locations  in the document. 

 

  

8) Text: -We use this option to insert the Text box, Header and Footer, Word 

art, Signature and objects. We insert Text box to write something in the image 

format. We use Header and Footer options to place the content on the top and 

bottom of the page. Word art makes the text stylish. Insert the Add Signature 

Lines that specify the individual who is supposed to sign it. And object option 

works for embedded objects, like documents or other files we have inserted into 

the document. 

 

 9) Symbols: - We use this option to insert the symbols and equation. Equation 

is used to insert the common mathematical equations to your document and also 

we can add equation by using the mathematical symbols. We use Symbols to 

http://www.exceltip.com/wp-content/uploads/2015/07/image-96.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-105.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-1110.png
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insert the symbols which are not on the keyboard and, to create the equation, 

we use the symbols from here. 

 

 

Charts in Excel 

Microsoft Excel no longer provides the chart 

wizard. Instead, you can create a basic chart 

by clicking the chart type that you want on 

the Insert tab in the Charts group.  Charts are 

used to display series of numeric data in a 

graphical format to make it easier to 

understand large quantities of data and the 

relationship between different series of data. 

To create a chart in Excel, you start by 

entering the numeric data for the chart on a 

worksheet. Then you can plot that data into 

a chart by selecting the chart type that you 

want to use on the Insert tab, in the Charts 

group.                                Worksheet data 
  Chart created from worksheet data 

 

javascript:AppendPopup(this,'762860362_1')
javascript:AppendPopup(this,'762860362_1')
http://www.exceltip.com/wp-content/uploads/2015/07/image-126.png
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Getting to know the elements of a chart 

A chart has many elements. Some of 

these elements are displayed by 

default, others can be added as 

needed. You can change the display 

of the chart elements by moving 

them to other locations in the chart, 

resizing them, or by changing the 

format. You can also remove chart 

elements that you do not want to 

display. 

1-The chart area is the entire 

chart and all its elements. 

2 -The plot area is the area of 

the chart bounded by the axes. 

3-The data points are individual 

values plotted in a chart 

represented by bars, columns, 

lines, or pies. 

4-The horizontal (category) and 

vertical (value) axis along which 

the data is plotted in the chart. 

5-The legend identifies the 

patterns or colors that are 

assigned to the data series or 

categories in the chart. 

6- A chart and axis title are 

descriptive text that for the axis or 

chart. 

7-A data label provides 

additional information about a 

data marker that you can use to 

identify the details of a data point 

in a data series. 

javascript:AppendPopup(this,'322311613_6')
javascript:AppendPopup(this,'728257652_7')
javascript:AppendPopup(this,'728257652_7')
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javascript:AppendPopup(this,'728257652_7')
javascript:AppendPopup(this,'306464758_9')
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Create a Chart 

1. On the worksheet, arrange the data that you want to plot in a chart. The 

data can be arranged in rows or columns — Excel automatically 

determines the best way to plot the data in the chart. 

2.  Select the cells that contain the data that you want to use for the chart. 

NOTE:  If the cells that you want to plot in 

a chart are not in a continuous range, you 

can select nonadjacent cells or ranges as 

long as the selection forms a rectangle. You 

can also hide the rows or columns that you 

do not want to plot in the chart. 

3.  Go to the Insert tab, in the Charts 

4.  Click the chart type, and then click a chart subtype from the drop menu that 

will appear. 

5.  Click anywhere in the embedded chart to activate it. When you click 

on the chart, Chart Tools will be displayed which includes the Design, 

Layout, and Format tabs. 

6.  The chart will automatically be embedded in the worksheet.  A chart 

name will automatically be assigned. 

 
Move Chart to New Sheet 

1.  On the Design tab, in the Location group, click Move Chart. 

2.  Under Choose where you want the chart to be placed, click on 

the New sheet bubble 

3.  Type a chart name in the New sheet box. 
 

Change Chart Name 

1.  Click the chart. 

2.  On the Layout tab, in the Properties group, click the Chart 

Name text box. 

3.  Type a new chart name. 

4.  Press ENTER. 
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Change Chart Layout 

1.  Click anywhere in the chart. 

2.  Go to the Chart Tools, the Design group 

3.  In the Chart Layouts, click the chart layout that you want to use. To see 

all available layouts, click 

More . 

 

 

 
 

Change Chart Style 

1.  Click anywhere in the chart. 

2.  On the Design tab, in the Chart Styles group, click the chart style that 

you want to use.  To see all predefined chart styles, click More . 

 
 
 
 
 

 

Chart or Axis Titles 

To make a chart easier to understand, you can add 

titles, such as chart and axis titles. To add a chart 

title: 

1.  Click anywhere in the chart. 

2.  On the Layout tab, in the Labels group, click 

Chart Title. 

3.  Click Centered Overlay Title or Above 

Chart. 

4.  In the Chart Title text box that appears in the 

chart, type the text that you want. 

5.  To remove a chart title, click Chart Title, and 

then click None. 

NOTE: You can also use the formatting buttons 

on the ribbon (Home tab, Font group). To format 

the whole title, you can right-click it, click 

Format Chart Title, and then 

select the formatting options that you want. 
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To add axis titles: 

1.  Click anywhere in the chart. 

2.  On the Layout tab, in the Labels group, click Axis Titles. 

3.  Do one or more of the following: 

a. To add a title to a primary horizontal (category) axis, click Primary 

Horizontal Axis Title, and then click the option that you want. 

b. To add a title to primary vertical (value) axis, click Primary Vertical 

Axis Title, and then click the option that you want. 

4.  In the Axis Title text box that appears in the chart, type the text that you 

want. 

5.  To remove an axis title, click Axis Title, click the type of axis title to 

remove, and then click None. 

 

Data Labels 

1.  On a chart, do one of the following: 

a.  Click on the chart area to add a data 

label to all data points of all data series 

b.  Click in the data series to add a data 

label to all data points of a 

data series 

c.   Click on a specific data point to add a 

data label to a single data point in a data 

series 

2. On the Layout tab, in the Labels group, click 

Data Labels, and then click the display option 

that you want. 

3.  Text boxes will appear in the area of your 

chart based on your selection. 

4.  Click on the text box to modify the text. 

5.  To remove data labels, click Data Labels, 

and then click None. NOTE: Depending on the 

chart type that you used, different data label 

options will be available.
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Legend 

When you create a chart, the legend appears, but you 

can hide the legend or change its location after you 

create the chart. 

1.  Click the chart in which you want to show or hide 

a legend. 

2.  On the Layout tab, in the Labels group, click 

Legend. 

3.  Do one of the following: 

a.  To hide the legend, click None. 

b.  To display a legend, click the display option 

that you want. 

c.   For additional options, click More Legend 

Options, and then select the display option that 

you want. 

NOTE: To quickly remove a legend or a legend entry 

from a chart, you can 

select it, and then press DELETE. You can also right-

click the legend or a legend entry, and then click 

Delete. 

 

Move or Resize Chart 

You can move a chart to any location on a worksheet 

or to a new or existing worksheet. You can also 

change the size of the chart for a better fit. 

To move a chart, drag it to the location that you want. 

To resize a chart, click on one of the edges and drag 

towards the center. 
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For instance, we have included a datasheet for which we want to create scatter 

graph and trend lines, it contains two fields; Distance (Km), and Time(Hrs). 

 
Now we want to create scatter graph which will show distance and time relation. 

For this, select the portion of the datasheet, navigate to Insert tab, and 

from Scatter options, select desired type of chart as shown in the screenshot 

below. 

 

 

 

 

 

 

 

 

 

 

https://www.addictivetips.com/microsoft-office/excel-2010-scatter-trendline/attachment/scatter-png/
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Upon clicking desired type of chart, Excel will automatically create a chart, 

representing table fields as x-axis, and y-axis respectively, as can be seen in the 

screen shot below. 

 

Now we will change the layout and design of the chart to make the value and 

scattered dots more prominent. For this select the chart, and you will notice 

under Chart Tools Design, Layout, and Format tab will appear. From Design tab 

choose the colors and design that best suits your datasheet. From Chart layouts 

select an appropriate layout for scatter chart. 

 

 

 

 

 

 

 

https://cloud.addictivetips.com/wp-content/uploads/2010/03/designtools.jpg
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Now navigate to Layout tab, and from Trendline options, click Linear 

Trendline. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You will be asked for which field you want to make trend lines, select the 

field, and click OK. Here you can see the trendiness, showing trend of the 

datasheet table in the screen shot below. 

https://www.addictivetips.com/microsoft-office/excel-2010-scatter-trendline/attachment/trendline1-png/
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Now if you want to know the trend exponentially, from Trendlines 

click Exponential Trenlines. 

 

 

 

https://www.addictivetips.com/microsoft-office/excel-2010-scatter-trendline/attachment/linear-png/
https://www.addictivetips.com/microsoft-office/excel-2010-scatter-trendline/attachment/expo-png/
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Formatting an Excel Trendline 

To format your newly-created trendline, begin by right clicking on the line and 

selecting Format Trendline from the menu. Excel will once again open up 

the Format Trendlinewindow. 

 

 
 

One of the more popular options people use when adding a trendline to Excel 

is to display both the equation of the line and the R-squared value right on the 

chart. You can find and select these options at the bottom of the window. For 

now, select both of these options. 

 

https://11986-presscdn-0-77-pagely.netdna-ssl.com/wp-content/uploads/2010/07/DisplayEquationandRsquareValueonChart.png
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Let’s say that we want our trendline to be displayed more prominently on the 

chart. After all, the default trendline is only one pixel wide and can sometimes 

disappear among the colors and other elements on the chart. On the left hand 

side of the Format Trendline window, click on the Line Style option. 

In this window, change the Width value from 0.75 pt to about 3 pt and change 

the Dash Type to the Square Dot option (third one down on the drop down 

menu). Just to demonstrate that the option exists, change the End Type option 

to an arrow. 

 

When you are done, click the Close button on the Format Trendline window 

and notice the changes to your scatter plot. Notice that the equation of the line 

and R-square values are now displayed on the chart and that the trendline is a 

more prominent element of the chart. 

From Layout tab, there are so much to do with scatter chart; you can create Error 

Bars, change Plot area, apply 3-D effects, Grid Lines etc. 

 

Apply desired Error Bars, 3-D effects, and gridlines to make the chart self-

explanatory. 

https://11986-presscdn-0-77-pagely.netdna-ssl.com/wp-content/uploads/2010/07/ChangeLineStyleinExcel.png
https://www.addictivetips.com/microsoft-office/excel-2010-scatter-trendline/attachment/layout12-png/
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Formulas Tab 

This tab has commands to use when creating Formulas. This tab holds an 

immense function library which can assist when creating any formula or 

function in your spreadsheet. 

 

 

 

 

 
 

 

4 groups of Formulas tab  

1-Function Library     2- Defined Names     3- Formula Auditing  4- 

Calculation 

 

1)   Function Library: -In Excel, we have 461 functions and they are available 

in the formulas tab under the function library group. And there is no need to 

learn every formula for we can find formulas category wise such as:- Financial, 

Logical, Text, Date & Time, Lookup & Reference, Math & Trig, many more. 

https://www.addictivetips.com/microsoft-office/excel-2010-scatter-trendline/attachment/cahrtnew-png/
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2)   Defined Names: -  We use this option to define the name of a cell, range 

and the list of the already defined name can be viewed in Name manager and 

we can edit it if we want to change the range or cell reference of any defined 

name. Also, we can use the defined name in Formulas. 

 

 c)   Formula Auditing: - This option helps us to identify the relation of 

formulas. By using Trace precedent, we get to know on which cell formula 

cell is based. Trace dependents are used to know if active cell is being used in 

any formula. When we use trace precedent and trace dependents the arrows 

get inserted automatically and, to remove the arrows, we use Remove Arrows. 

Show formula is a self-explained word; it is used to show the formula in the 

sheet. Error checking is used to check the error in the sheet. Evaluate formula 

option is used to evaluate the formula step by step. 

 

  

d)   Calculation: -If we want to switch the calculation from automatically to 

manually calculation and manually to automatically calculation, then we can do 

it by using the Calculation option. We use Calculate Now and Calculate Sheet 

option if automatic calculation is turned off. 

 
 

http://www.exceltip.com/wp-content/uploads/2015/08/image-3.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-4.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-5.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-6.png
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Formulas are equations that perform calculations on values in your worksheet. 

A formula always starts with an equal sign (=).  An example of a simple is 

=5+2*3 that multiplies two numbers and then adds a number to the result. 

Microsoft Office Excel follows the standard order of mathematical 

operations. In the preceding example, the multiplication operation (2*3) is 

performed first, and then 5 is added to its result. 

You can also create a formula by using a function which is a prewritten 

formula that takes a value, performs an operation and returns a value.  For 

example, the formulas =SUM(A1:A2) and SUM(A1,A2) both use the SUM 

function to add the values in cells A1 and A2. Depending on the type of 

formula that you create, a formula can contain any or all of the following 

parts. 

 

Functions A function, such as PI() or 

SUM(), starts with an equal sign (=). 

Cell references You can refer to data in 

worksheet cells by including cell references in 

the formula. For example, the cell reference A2 

returns the value of that cell or uses that value in the calculation. 

  Constants You can also enter constants, such as numbers (such as 2) or 

text values, directly into a formula. 

 Operators Operators are the symbols that are used to specify the type of 

calculation that you want the formula to perform. 

Create a Simple Formulas 

1.  Click the cell in which you want to 

enter the formula. 

2.  Type = (equal sign). 

3.  Enter the formula by typing the 

constants and operators that you 

want to use in the calculation. 

4.  Press ENTER. 

 

 

 

 

Example Formula  What it dose  

=5+2                Adds 5 and 2 

=5^2                Raises 5 to the 

2nd power 

=5/2                 Divides 5 by 2 

=5*2                Multiplies 5 times 

2 
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Create a Formula with Cell Reference 

 1-The first cell reference is B3, the color is 

blue, and the cell range has a blue border 

with square corners . 

2-The second cell reference is C3, the 

color is green, and the cell range has a 

green border with square corners.  
 

To create your formula: 

1.  Click the cell in which you want to enter the formula. 

2.  In the formula bar, at the top of the Excel window that you use, ,  

type = (equal sign). 

3.  Click on the 1st cell you want in the formula. 

4. Enter an operator such as +, or *. 

5.  Click on the next cell you want in the formula. Continue steps 3 - 5 until 

the formula is complete 

6.  Hit the ENTER key on your keyboard. 

Create Formula with Function  

1-Click the cell in which you want to 

enter the formula. 

2- Click Insert Function  on the 

formula bar .  Excel inserts 

the equal sign (=) for you. 

3- Select the function that you want to 

use. 

NOTE: If you're not sure which function 

to use, type a question that describes 

what you want to do in the Search for a 

function box (for example, "add 

numbers" returns the SUM function), or 

browse from the categories in the Or 

Select a category box. 

4.  Enter the arguments. 

5.  After you complete the formula, press 

ENTER 

  

 

javascript:AppendPopup(this,'665135067_9')
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Use Auto Sum 

To summarize values quickly, you can 

also use AutoSum. 

1.  Select the cell where you would like 

your formulas solution to appear. 

2.  Go to the Home tab, in the Editing 

group, 

3.  Click AutoSum, to sum your numbers 

or click the arrow next to AutoSum to 

select a function that you want to apply. 

 

 

Delete a Formula 

When you delete a formula, the resulting values of the formula is also deleted. 

However, you can instead remove the formula only and leave the resulting 

value of the formula displayed in the cell. 

   To delete formulas along with their resulting values, do the following: 

1.  Select the cell or range of cells that contains the formula. 

2.  Press DELETE. 

 

 

 

To delete formulas without removing their resulting values, do the following: 

1-Select the cell or range of cells that contains the formula. 

2-On the Home tab, in the Clipboard group, click Copy . 

3- On the Home tab, in the Clipboard group, click the arrow below Paste   , and 

then click Paste Value. 

Using the IF function in Excel - formula examples 

The use of the IF function with numeric values is based on using different 

comparison operators to express your conditions. You will find the full list of 

logical operators illustrated with formula examples in the table below. 
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Condition 
Operat

or 

Formula 

Example 
Description 

Greater than > 
=IF(A2>5, 

"OK",) 

If the number in cell A2 is greater 

than 5, the formula returns "OK"; 

otherwise 0 is returned. 

Less than < 
=IF(A2<5, "OK", 

"") 

If the number in cell A2 is less 

than 5, the formula returns "OK"; 

an empty string otherwise. 

Equal to = 
=IF(A2=5, "OK", 

"Wrong number") 

If the number in cell A2 is equal to 

5, the formula returns "OK"; 

otherwise the function displays 

"Wrong number". 

Not equal to <> 

=IF(A2<>5, 

"Wrong number", 

"OK") 

If the number in cell A2 is not 

equal to 5, the formula returns 

"Wrong number "; otherwise - 

"OK". 

Greater than or equal to >= 
=IF(A2>=5, 

"OK", "Poor") 

If the number in cell A2 is greater 

than or equal to 5, the formula 

returns "OK"; otherwise - "Poor". 

Less than or equal to <= 
=IF(A2<=5, 

"OK", "") 

If the number in cell A2 is less 

than or equal to 5, the formula 

returns "OK"; an empty string 

otherwise. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

=If(b2>= 90 ,”امتياز”, If(b2>=80,”جيد جدا”, IF(B2> =70 ,"جيد", IF (B2> =60, 

 ((((("مقبول","راسب",B2>=50)IF, "متوسط"
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Data Tab 

This tab allows you to modifying worksheets with large amounts of data by 

sorting and filtering as well as analyzing and grouping data. 
 

 

 

 
 

  

 

Data tab contains 5 groups:- 1- get external data     2- Connections      3 – sort 

& filter 4- data Tools 5- outline  

 1)  Get External Data: - In Excel, we can import data from MS Access, Web, 

Text and other sources. Also, we can import the data from other applications. 

 

  

2)    Connections: -It is used to display the entire data connections for the 

workbook. Data connections are links to the data outside the workbook which 

can be updated if the source data changes. And updated data can be obtained by 

refreshing all sources in workbook. 

 

 3) Sort & Filter: -To set the data in ascending or descending order on the basis 

of value or as per the first letter of a word, we use Sort option. Also, we can put 

the basic and advanced filter from here only. 

http://www.exceltip.com/wp-content/uploads/2015/08/image-32.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-42.png
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4)  Data Tools: -This option is very important to make the report interactive; it 

helps us to make the data authentic, and using this tab, we can restrict or validate 

the entries if the data is being updated by multiple users. Text to Columns helps 

us to split the single column into multiple columns as per data. Flash fills the 

values in the range. We can delete duplicate rows from the data by using 

Remove Duplicates option. We use Data Validation to provide the list that can 

be entered in cell, or we can restrict the entries, or we can validate the entries 

in the cell. We use Consolidate option to summarize data from separate ranges, 

and consolidate the result in a single output range. We use What-if-Analysis to 

analyse the data. 

 

  

e)    Outline: -We use this option to make the data more analytical and 

understandable. We can make group of rows or columns or automatically create 

an outline. We can ungroup the data; quickly calculate rows of related data by 

inserting subtotals and totals. We use Show and Hide options when we want to 

insert the Subtotal in data. 

 
 

Add Data Analysis  

The Analysis ToolPak is an Excel add-in program that provides data analysis 

tools for financial, statistical and engineering data analysis. To load the 

Analysis ToolPak add-in, execute the following steps. 

1. On the File tab, click Options. 

http://www.exceltip.com/wp-content/uploads/2015/08/image-52.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-62.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-7.png
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2. Under Add-ins, select Analysis ToolPak and click on the Go button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Check Analysis ToolPak and click on OK. 
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4. On the Data tab, in the Analysis group, you can now click on Data 

Analysis. 

 

5.The following dialog box below appears. For example T- test  
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This example teaches you how to perform a t-Test in Excel. The t-Test is used 

to test the null hypothesis that the means of two populations are equal. 

Below you can find the study hours of 6 female students and 5 male students. 

H0: μ1 - μ2 = 0 

H1: μ1 - μ2 ≠ 0 

 

To perform a t-Test, execute the following steps. 

1. First, perform an F-Test to determine if the variances of the two populations 

are equal. This is not the case. 

2. On the Data tab, in the Analysis group, click Data Analysis. 

 

Note: can't find the Data Analysis button? Click here to load the Analysis 

ToolPak add-in. 

3. Select t-Test: Two-Sample Assuming Unequal Variances and click OK. 

 

4. Click in the Variable 1 Range box and select the range A2:A7. 

http://www.excel-easy.com/examples/f-test.html
http://www.excel-easy.com/data-analysis/analysis-toolpak.html
http://www.excel-easy.com/data-analysis/analysis-toolpak.html
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5. Click in the Variable 2 Range box and select the range B2:B6. 

6. Click in the Hypothesized Mean Difference box and type 0 (H0: μ1 - μ2 = 0). 

7. Click in the Output Range box and select cell E1. 

 

8. Click OK. 

 

 

Result: 

 

Conclusion: We do a two-tail test (inequality). lf t Stat < -t Critical two-tail or 

t Stat > t Critical two-tail, we reject the null hypothesis. This is not the case, -

2.365 < 1.473 < 2.365. Therefore, we do not reject the null hypothesis. The 

observed difference between the sample means (33 - 24.8) is not convincing 
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enough to say that the average number of study hours between female and male 

students differ significantly. 
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Page Layout Tab 

This tab has commands to adjust page such as margins, orientation and 

themes. 

 
 

 

 

 

 

 

 

 

In this menu tab, we have 5 groups:- 1- Themes   2- Page setup   3- scale to fit  

4- sheet option  5- arrange  

 

1)    Themes: - This option is used to change the theme color of workbook by 

just click of a button. Each theme has 12 colors, two fonts (heading and body), 

SmartArt and the effects for shape. Also, we have color option whereby we 

can create new color’s theme, by using the Font option, we can create new 

font theme as well. So, if we want to create our own theme we can create it 

by using Themes option in Excel. 

 
  

2)    Page Setup: -We use this option to set up the page for printing. So, we 

have Margins, Orientation, Size, Print Area, Breaks, Background and Print 

titles, in this group, which we use to prepare the page for printout. 

 
  

http://www.exceltip.com/wp-content/uploads/2015/07/image-317.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-416.png
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3)    Scale to Fit: -This option helps to fit the page for printing by shrinking 

or enlarging its size to better fit the pages. We can use Scale to fit to adjust 

the width and height by describing the scale %age. 

 
  

4)    Sheet Options: -It is also a printing option that can show or hide the 

gridlines, while printing and heading options are used to give headings to the 

rows and columns. 

 
  

5)    Arrange: -We use this option to arrange the objects back and forward 

and align it. Also, we have Selection pane option by which we can see total 

images in the workbook and select them from there. 
 

Review Tab 

This tab allows you to correct spelling and grammar issues as well as set up 

security protections. It also provides the track changes and notes feature 

providing the ability to make notes and changes someone’s document. 
 
 
 
 
 
 
 
 
 

 
 

 

Review tab contains 4 groups:- 1- Proofing     2- Language        3- Comments      

4- Changes  

  

 

http://www.exceltip.com/wp-content/uploads/2015/07/image-77.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-77.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-58.png
http://www.exceltip.com/wp-content/uploads/2015/07/image-67.png


56 
 

  

1)    Proofing: -We use proofing to correct the typo mistakes through spelling 

option. Research and dictionary work alike. And Thesaurus suggests other 

ways to say anything. 

 
  

2)    Language: - We use this optionto translate the sentence in any other 

language. 

 
  

3)    Comment: -When we want to give the message about the cell, we use 

comment option. We can insert and delete the comment, show and hide the 

comment, and then we have an option to show all the comments. 

 
  

4)    Changes: - We use Changes option to protect the sheet and workbook, 

and we can allow user to edit the specific range; also, we can share the 

workbook as well. When we want to prevent the unwanted changes in the 

sheet by others, we can protect the sheet by using the “Protect Sheet” option. 

And, if we don’t want other users to do any structural changes in the workbook 

such as moving, deleting or adding sheets, we can do it by using the “Protect 

workbook” option. Using “Share workbook” option, we can grant access to 

multiple users to work on a file at the same time. We use “Protect and share 

workbook” option to share the workbook and protect change tracking with a 

password. We use “Allow users to edit ranges” to set up password protection 

http://www.exceltip.com/wp-content/uploads/2015/08/image-33.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-43.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-53.png
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on few ranges and we can select the users who can edit those ranges. We use 

“Track changes” to keep the track of changes made in the file. 
 

View Tab 

This tab allows you to change the view of your document including freezing 

or splitting panes, viewing gridlines and hide cells. 

 

 

 

 

 

 

 

View tab contains 5 groups:- 1- workbook views     2- show      3- zoom     4- 

window    5- Macro 

  

1)    Workbook Views: -Excel offers 4 types of workbook views: – Normal, 

Page break preview, Page layout & Custom View. We use “Normal” option 

to see the normal view of Excel. We use Page break preview option to see that 

where the page-breaks appear when we print the document. Through “Page 

layout” option, we can check  from where does the page begin and end as well 

as to see any header / footer on the page. We use Custom View option to save 

the current display and setting as a custom view which we can apply in future. 

 
  

2)    Show: – We use this option to show and hide the Excel’s view. Ruler is 

used to show the rulers next to our documents. Grid lines option is used to 

show the lines between rows and columns in the sheet to make the sheet easier 

to read. Through Formula bar, we can obtain the formula for the active cell. 

Heading is used to show the heading of columns and rows number. 

http://www.exceltip.com/wp-content/uploads/2015/08/image-63.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-63.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-34.png
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3)    Zoom: -We can adjust the view as per our convenience. Zoom 100% is 

the standard view for viewing the Excel file. We use Zoom to selection to 

zoom the sheet so the selected range of cells fills the entire window. 

 
  

4)    Window: -We use this option to access the window options. New window 

is used to open the same document in the new window, and we can perform 

in the both windows and thus both documents will get updated. Arrange all 

option helps us to stack the already opened window so that we can see all of 

them at once. Freeze Panes option is very useful for viewing vast data with 

the headers or we can use it to mark the comparison. Its usage always depends 

on requirement. Split option is used to divide the window into different panes 

such that each scrolls separately. Hide option is used to hide the current 

window. 

 
  

5)    Macros: -With this option, we can record the macro and then we can 

view the macro. 

 
 

http://www.exceltip.com/wp-content/uploads/2015/08/image-44.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-54.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-64.png
http://www.exceltip.com/wp-content/uploads/2015/08/image-71.png
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Advanced Spreadsheet Modification 

Once you have created a basic spreadsheet there are numerous things you 

can do to make working with you data easier.  Some of these elements are 

hiding, freezing and splitting rows.  You can also sort and filter data, these 

features are quite helpful when working with a large amount of data. 

Hide or Display Rows and Columns 

You can hide a row or column by using the Hide 

command or when you change its row height or 

column width to 0 (zero). You can display either 

again by using the Unhide command.  You can 

either unhide specific rows and columns, or you 

can unhide all hidden rows and columns at the 

same time. The first row or column of the 

worksheet is tricky to unhide, but it can be done. 

Hide Rows or Columns 

1. Select the rows or columns that you want to 

hide. 

2. On the Home tab, in the Cells group, click 

Format. 

3. Under Visibility, point to Hide & Unhide, and 

then click Hide 

Rows or Hide Columns. 

NOTE: You can also right-click a row or column 

(or a selection of multiple rows or columns), and 

then click Hide. 

Unhide Rows or Columns 

1.  Select the rows, columns or entire sheet to unhide. 

2.  On the Home tab, in the Cells group, click Format. 

3.  Under Visibility, point to Hide & Unhide, and then click Unhide 

Rows or Unhide Columns. 

TIP You can also right-click the selection of visible rows and columns 

surrounding the hidden rows and columns, and then click Unhide. 
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Freezing/Splitting Rows and Columns 

To keep an area of a worksheet visible while you scroll to another area of 

the worksheet, you can either lock specific rows or columns in one area by 

freezing panes. 

Freezing vs. splitting 

When you freeze panes, Microsoft Excel 

keeps specific rows or columns visible 

when you scroll in the worksheet. For 

example, if the first row in your spreadsheet 

contains labels, you might freeze that row to 

make sure that the column labels remain 

visible as you scroll down in your 

spreadsheet.  A solid line indicates that the 

row is frozen to keep column labels in place 

when you scroll. 

When you split panes, Excel creates either 

two or four separate worksheet areas that 

you can scroll within, while rows or 

columns in the non-scrolled area remain 

visible.  This worksheet has been split into 

four areas. Notice that each area contains 

a separate view of the same data.  Splitting 

panes is useful when you want to see 

different parts of a large spreadsheet at the 

same time. 

NOTE: You cannot split panes and freeze 

panes at the same time. 

Freeze Panes 

1.  On the worksheet, select the row or column that you want to keep visible 

when you scroll. 

2.  On the View tab, in the Window group, click the arrow below Freeze 

Panes. 
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3. Then do one of the following: To lock one column only, click Freeze 

First Column. To lock more than one row or column, or to lock both rows 

and columns at the same time, click Freeze Panes. 

 

 

 

 

 

 

NOTE: You can freeze rows at the top and columns on the left side of the 

worksheet only. You cannot freeze rows and columns in the middle of the 

worksheet. 

Unfreeze panes 

1.  On the View tab, in the Window group, click the arrow below Freeze 

Panes. 

2.  Click Unfreeze Panes. 

Split  

1.  To split panes, point to the split box at the top of 

the vertical scroll bar or at the right end of the 

horizontal scroll bar. 

2.  When the pointer changes to a split pointer or 

 , drag the split box down or to the left to the 

position that you want.  

3.  To remove the split, double-click any part of the 

split bar that divides the panes. 
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Moving or Copying Worksheets 

Sometimes you may need to copy an entire 

worksheet instead of copying and pasting the data 

which may or may not paste properly, you can use 

the steps below to achieve a must better result. 

Move or Copy Worksheets 

1. Select the worksheets that you want to move or 

copy. 

2. On the Home tab, in the Cells group, click 

Format, and then under Organize Sheets, click 

Move or Copy Sheet.  You can also right-click a 

selected sheet tab, and then click Move or Copy. 

3.  A Move or Copy dialog box will appear  

4.  To move a sheet, in the Before sheet list: 

   Click the sheet that you want to insert the 

moved or copied sheets directly in front of. 

  Click move to end to insert the moved or copied 

sheets after the last sheet in the workbook and before 

the Insert Worksheet tab. 

 

5.  To copy the sheets, in the Move or Copy dialog 

box, select the Create a copy check box. 

NOTE: When you create a copy of the worksheet, the worksheet is 

duplicated in the workbook, and the sheet name indicates that it is a copy — 

for example, the first copy that you make of Sheet1 is named Sheet1 (2). 

NOTE: To move sheets in the current workbook, you can drag the selected 

sheets along the row of sheet tabs. To copy the sheets, hold down CTRL, 

and then drag the sheets; release the mouse button before you release the 

CTRL key. 

Move or Copy to a Different Workbook 

1.  In the workbook that contains the sheets  that you want to move or copy, 

select the sheets. 

2.  On the Home tab, in the Cells group, click Format, and then under 
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Organize Sheets, click Move or Copy Sheet. 

3.  In the Move or Copy dialog box, click the drop 

down list in the To book box, then: 

Click the workbook to which you want to 

move or copy the selected sheets. 

Click new book to move or copy the 

selected sheets to a new workbook. 

6.  To move a sheet, in the Before sheet list: 

    Click the sheet that you want to insert the moved or copied sheets directly in 

front of. 

    Click move to end to insert the moved or copied sheets after the last sheet 

in the workbook and 

before the Insert Worksheet tab. 

7.  To copy the sheets, in the Move or Copy dialog box, select the Create a 

copy check box. 

Sorting Data 

Sorting data is an integral part of data analysis. You might want to arrange a 

list of names in alphabetical order, compile a list of product inventory levels 

from highest to lowest, or order rows by colors or icons. Sorting data helps 

you quickly visualize and understand your data better, organize and find the 

data that you want, and ultimately make more effective decisions. 

Sort Data in Single Column 

1.  Select a column of data in a range of cells 

2.  On the Data tab, in the Sort & Filter group, do one of the following: 

   To sort in ascending or smallest to largest 

order, click Sort A to Z.   To sort in 

descending or largest to smallest order, click 

Sort Z to A. 

3.  To reapply a sort after you change the data, click a cell in the range or 

table and then, on the Data tab, in the Sort & Filter group, click Reapply. 
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Sort Data in Multiple Columns or Rows 

You may want to sort by more 

than one column or row when 

you have data that you want to 

group by the same value in 

one column or row, and then 

sort another column or row 

within that group of equal 

values. 

1.  Select a range of cells 

with two or more columns of 

data. 

2.  On the Data tab, in the 

Sort & Filter group, click 

Sort. 

3.  The Sort dialog box will 

appear. 

4.  Under Column, in the 

Sort by box, select the 

first column that you 

want to sort. 

5.  Under Sort On, select the 

type of sort. 

    To sort by text, number, or date and time, select Values. 

    To sort by format, select Cell Color, 

Font Color, or Cell Icon. 

6.  Under Order, select how you want to sort. 

For text values, select A to Z or Z to A. For 

number values, select Smallest to Largest or 

Largest to Smallest. 

For date or time values, select Oldest to 

Newest or Newest to Oldest. To sort based 

on a custom list, select Custom List. 
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7.  To add another column to sort by, click Add Level, and then repeat steps 

four through six. 

8.  To copy a column to sort by, select the entry and then click Copy Level. 

9.  To delete a column to sort by, select the entry and then click Delete Level. 

10. To change the order in which the columns are sorted, select an entry and 

then click the Up or Down arrow to change the order. 

11. To reapply a sort after you change the data, click a cell in the range or 

table and then, on the Data tab, in the Sort & Filter group, click Reapply. 

Finalizing a Spreadsheet 

To complete your spreadsheet there are a few steps to take to 

ensure your document is finalized. Using the "Spell Check" 

Feature 

Excel does not have the same spell check feature as Word and PowerPoint.  

To complete a Spelling and Grammar check, you need to use the Spelling and 

Grammar feature. 

1.  Click on the Review tab 

2.  Click on the Spelling & Grammar command (a blue check mark with 

ABC above it). 

3.  A Spelling and Grammar box will appear, correct any 

Spelling  

 


